Microsoft Office

Excel: Wenn-Dann-Funktion - so funktioniert sie!

Mit der Funktion WENN() lassen sich in Excel komplexere Aufgabenstellungen elegant lösen. Unsere Anleitung für Wenn-Dann-Funktionen hilft weiter!

Microsoft Office - Excel

© Screenshot WEKA / PC Magazin

Die Syntax der Funktion ist in Excel mit WENN(Wahrheitstest; [Wert_wenn_wahr]; [Wert_ wenn_falsch]) angegeben. Wahrheitstest ist eine Bedingung, die wahr oder falsch sein kann. Für die Formulierung der Bedingung können Sie die folgenden Operatoren verwenden: = (gleich), <> (un- gleich), > (größer als), < (kleiner als), >= (größer oder gleich), <= (kleiner oder gleich)

Nach der Bedingung und einem Semikolon wird der Wert notiert, den die Funktion zurückgeben soll, wenn die Bedingung zutrifft, und als Letztes – wiederum getrennt durch ein Semikolon – der Wert, wenn sie nicht zutrifft, z.B. =WENN(A1>1000; „Rabatt“; „Kein Rabatt“). Diese Formel schreibt in die Zelle, in der sie ausgeführt wird, den Text Rabatt, falls ein in Zelle A1 angegebener Geldbetrag größer als 1.000 ist. 

Trifft das nicht zu, schreibt sie den Text Kein Rabatt in die Zelle. Oft ist es auch zweckmäßig, Excel-Funktionen, die einen Wahrheitswert zurückgeben, in der Bedingung zu verwenden. Angenommen, in die zweite Spalte eines Tabellenblatts soll die Mehrwertsteuer eines in der ersten Spalte angegebenen Nettobetrags geschrieben werden. 

Um zu prüfen, ob in der ersten Spalte auch wirklich eine Zahl steht, und die Berechnung nur in diesem Fall durchzuführen, könnte man z.B. für die Zelle B2 folgende Formel notieren: =WENN(ISTZAHL(A2); A2*19/100; „“).

Mehr lesen

word excel autospeichern einstellen
Auto-Backups in Office 2010, 2013, 2016

Wie Sie in Microsoft Office (Word, Excel & Powerpoint) mit den Funktionen AutoSpeichern und Sicherungskopie Ihre Dokumente richtig sichern.

Die Bedingung ISTZAHL(A2) gewährleistet, dass die Berechnung A2*19/100 für die Zelle B2 nur dann durchgeführt wird, wenn die Zelle A2 auch tatsächlich einen als Zahl interpretierbaren Wert enthält. Falls das nicht der Fall ist, bleibt die Zelle B2 leer („“ als zweites Argument der WENN-Funktion). 

Sie müssen sich beim zweiten und dritten Parameter der WENN-Funktion aber nicht darauf beschränken, einen bloßen Wert anzugeben, sondern können zunächst auch weitere Aktionen festlegen. So ist es z. B. möglich, mehrere WENN-Funktionen ineinanderzuschachteln.

Dementsprechend liefert die folgende Formel in Abhängigkeit von einer in Zelle A1 angegebenen Bestellmenge drei unterschiedliche Angaben für den Rabatt: =WENN(A2>100; WENN(A2>200; „15 % Rabatt“; „10 % Rabatt“); „Kein Preisnachlass“)

Beachten Sie, dass die Prüfung von A2>200 nur erfolgt, wenn A2>100, was als Erstes geprüft wird, zutrifft. Eine andere Formulierung mit dem gleichen Ergebnis wäre z.B. =WENN(A2>200; „15 % Rabatt“; WENN(A2>100; „10 % Rabatt“; „Kein Preisnachlass“)).

Tipp: In unserem Gutschein-Portal finden Sie aktuelle TOMTOP-Gutscheine und -Gutscheincodes.

Mehr zum Thema

Szenarien in Excel
Was wäre wenn

Eine wichtige Basis für Entscheidungen ist zu wissen, welche Annahmen zu welchen Ergebnissen führen. Ein spezielles Excel-Tool ist hier eine große…
Microsoft Office Word
Tipps & Tricks

Wer in Excel vielen Zellen stets gleiche Formate verpasst, arbeitet mit Vorlagen. Wir zeigen in diesem Tipp, wie Sie diese Formatvorlagen für Zellen…
Planen mit Excel
Microsoft Office

Datenverarbeitung mit Office ist großartig: Doch irgendwann reichen die Möglichkeiten von Excel nicht mehr aus. Wir helfen Ihnen beim Wechsel auf…
Mit Excel Stammbaum erstellen
Office-Praxis

Wenn Sie Interesse an Ahnenforschung haben, kann Microsoft Excel helfen. Unsere Anleitung zeigt, wie Sie einen Stammbaum erstellen können.
excel nach farben sortieren
Anleitung

Unsere kurze Anleitung zu Microsoft Office erklärt Schritt für Schritt, wie Sie eine Auflistung in Excel nach Farben sortieren.