Office-Tipps für Einsteiger

Excel: Nur jede n-te Zelle addieren

Nicht selten muss man aus Spalten oder Zeilen nur jede zweite, dritte, vierte ... Zelle addieren. Mit einer Formel geht das sehr einfach.

Excel: Nur jede n-te Zelle addieren

© Hersteller

Excel: Nur jede n-te Zelle addieren

Nehmen wir also einmal an, unsere Zahlen stehen in den Spaltenzellen B2 bis I2 und wir möchten beginnend mit dem Wert aus B2 jeden weiteren zweiten Wert addieren. Die Spalte B ist als zweite Spalte einer Excel-Tabelle eine "gerade" Spalte. Da wir also mit einer geraden Spalte beginnen, kommt in der Formel der Index "0" (Null) zur Anwendung.

Möchten wir mit der Spalte C beginnen, ist die erste Spalte eine "ungerade" Spalte und in der Formel wird der Index "1" verwendet.

Hier nun die Formel für die Addition der Werte aus B2, D2, F2 und G2:

  • {=SUMMENPRODUKT((REST(SPALTE(B2:I2);2)=0)*(B2:I2))}

Die geschweiften Klammern am Anfang und am Ende der Formel weisen auf eine Array-Formel hin. Diese werden der Formel hinzugefügt, wenn Sie am Schluss der Formeleingabe die Tastenkombination "Strg+Shift(Großbuchstabe)+Enter" drücken.

Eine Array-Formel ist eine Formel, welche sich auf Bereiche und nicht auf einzelne Zellen bezieht. Für die Addition jeder zweiten "ungeraden" Spalte aus dem Wertebereich schreiben Sie die Array-Formel:

  • {=SUMMENPRODUKT((REST(SPALTE(B2:I2);2)=1)*(B2:I2))}

Möchten Sie jeden 3. Wert addieren, schreiben Sie nach der ersten Bereichsangabe statt einer "2" eine "3" ... (Spalte(B2:I2);3 ..., bei jedem vierten Wert eine "4" und so weiter.

Für die übergreifende Addition jedes zweiten Wertes in nur einer Spalte (also senkrecht) schreiben Sie beispielsweise den Bereich ... (ZEILE(B2:B9);2)=0)*(B2:B9))} für gerade Zeilen oder ... (ZEILE(B2:B9);2)=1)*(B2:B9))} für ungerade Zeilen.

Mehr zum Thema

Microsoft Office Workshop für Kopf- & Fußzeilen in Excel.
Anleitung zu Microsoft Office

Wie füge ich Kopf- und Fußzeilen in Excel ein? Die Lösung auf diese oft gestellte Frage, geben wir in dieser Anleitung zu Microsoft Office. So…
Word - Tabelle sortieren
Office-Tipp

Mit wenigen Klicks können Sie in Word eine Tabelle sortieren - etwa nach Text, Zahl oder Datum. Wir zeigen, wie das geht.
Excel Zellenformatvorlagen
Office-Tipp

In diesem schnellen Office-Tipp zeigen wir Ihnen, wie Sie in Excel mit Zellenformatvorlagen eine Menge Arbeit sparen.
Excel - Nettoarbeitstage
Office-Tipp

Wir erklären, wie Sie in Excel etwa für eine Arbeits- oder Urlaubsplanung die Wochenenden herausrechnen und die Nettoarbeitstage berechnen.
Kalender synchronisiert auf iPad
Zeit-Management

Kalender auf dem Smartphone, PC und im Web synchronisieren - mit unseren 9 Tipps schaffen Sie genau das. Verpassen Sie keinen Termin mehr!