Office-Tipp

Excel: Datenüberprüfung mit ZÄHLENWENN

So verhindern Sie in einem bestimmten Tabellenbereich das Vorkommen doppelter Werte.

Tipps zu Excel 2010

© PC Magazin

Tipps zu Excel 2010

Produkt- oder Kundennummern müssen eindeutig bleiben. Kein Benutzer darf im entsprechenden Tabellenbereich doppelte Werte eingeben. Markieren Sie dazu die betreffenden Zellen und klicken Sie im Register Daten auf die Schaltfläche Datenüberprüfung - unter Office 2003 den Menübefehl Daten/Gültigkeit.

Im Dialogfenster Datenüberprüfung (Office 2003: Gültigkeitsprüfung) stellen Sie auf der ersten Registerkarte im Listenfeld unter Zulassen: die Option Benutzerdefiniert ein. Als Formel geben Sie =ZÄHLENWENN($<Buchstabe der ersten Zelle>$<Nummer der ersten Zelle>:$ <Buchstabe der letzten Zelle>$<Nummer der letzten Zelle>; <Buchstabe der ersten Zelle>)=1 an. Für die Platzhalter <...> setzen Sie die Zellenangaben ein. Für die Zellen B3 bis B11 lautet die Formel =ZÄHLENWENN($B$3:$B$11;B3)=1.

Beachten Sie bitte, dass Sie den Bereich absolut (Dollarzeichen) und das Kriterium - hier die jeweils erste Zelle des Bereichs - relativ (ohne Dollarzeichen) definieren müssen. Im Übrigen muss sich der zu überprüfende Bereich nicht auf eine Spalte erstrecken. So validieren Sie mit =ZÄHLENWENN($A$1:$C$10;A1)=1 den Tabellenbereich von A1 bis C10. Überzeugen Sie sich, dass im Register Fehlermeldung die Option Fehlermeldung anzeigen, wenn ungültige Daten eingegeben wurden aktiviert ist, und geben Sie hier Titel und Text für die Fehlermeldung an. Bestätigen Sie den Dialog Datenüberprüfung schließlich mit OK.

Mehr zum Thema

Bugs in Microsoft Office
Karl Klammers Erben

Leider hat Office nicht erst mit Karl Klammer nervige Features im Angebot. Die Unfähigkeit, mit negativen Uhrzeiten zu rechnen und Druckprobleme…
Excel-Tipp: Verwenden von Pivot-Tabellen
Microsoft Office

Pivot-Tabellen bieten ohne zusätzlichen Aufwand geniale Filtermöglichkeiten, Gruppierungen und Rechenfunktionen. Besonders bei größeren…
PC mit Familie teilen
Benutzerkonten, History löschen & Co.

Soll Ihr PC für mehrere Benutzer bereitstehen und Sie wollen mehr Privatsphäre? Wir zeigen, wie Sie Benutzerkonten anlegen, Spuren löschen und…
Windows 10
Nach Windows 10 Update

KB3086786: Dateien von Word, Excel und Powerpoint, die unter Windows 7 erstellt wurden, können nach dem Update auf Windows 10 Probleme machen.
Windows 10
"Private Abhöranlage"

"Private Abhöranlage": Die Datenschutzbestimmungen von Windows 10 rufen Verbraucherschützer auf den Plan. Doch ganz hilflos ist der Anwender nicht.