Wie Excel Access das Fürchten lehrt

Die Funktion DBMIN()

Die Funktion DBMIN()

Leider werden bei den Datenbankfunktionen nur die Ergebnisse, nicht jedoch die dazugehörigen Datensätze ausgewiesen. Dies kann man jedoch mit einem Trick nachbessern und die Liste somit noch viel aussagekräftiger gestalten. Sie benötigen hierfür einige WENN-Bedingungen und die bedingte Formatierung. Wenn Sie beispielsweise auf einen Blick sofort erkennen möchten, um welchen Datensatz es sich handelt, der den geringsten Tages-Absatz (Menge) im Bereich Drucker am oder nach dem 15.03.2008 (>=15.03.2008) beinhaltet, dann müssen Sie wie folgt vorgehen:

1. Isolieren Sie zuerst in Zelle A3 das Datum, gegen das (später) geprüft wird mit der Formel =WENN(LÄNGE(A2)=5;A2;WENN(LÄNGE(A2)=11;RECHTS(A2;10);WENN(LÄNGE(A2)=12;RECHTS(A2;10))))

2. Isolieren Sie weiterhin in Zelle A4 die Bedingungen für das Datum über die Formel =WENN(LINKS(A2;2)=">=";">=";WENN(LINKS(A2;2)="<=";"<=";WENN(LINKS(A2;1)="<";"<";WENN(LINKS(A2;1)=">" ;">";"="))))

3. Schaffen Sie sich dann im Bereich I3 bis Q19 weitere Hilfszellen zur:

a) Datumsprüfung: Über die Formel =WENN(UND($A$4="<=";DATUM(JAHR($A$3);MONAT($A$3);TAG($A$3))>=A6);1;"") in Zelle I6 wird beispielsweise abgeprüft, ob das Datum in Zelle A6 den Kriterien im Zellenbereich A2:A3 entspricht und bei Zutreffen der Bedingung der Wert 1 über die Wenn-Funktion zurückgegeben. In den Spalten J:N werden diese Datumsprüfungen in Abhängigkeit vom Kriterium in Zelle A4 fortgesetzt.

b) Kategorieprüfung: In Spalte O wird in der jeweiligen Zeile geprüft, ob das Kriterium in Zelle B2 dem Eintrag in der Spalte B entspricht und bei Übereinstimmung eine 1 durch die Funktion zurückgegeben.

c) Wertprüfung: In Spalte P wird in der jeweiligen Zeile geprüft, ob das Kriterium in Zelle G2 dem Eintrag in der Spalte B entspricht und bei Übereinstimmung eine 1 durch die Funktion zurückgegeben.

d) Prüfergebnisse für die bedingte Formatierung aufbereiten: In Spalte Q schließlich werden die Ergebnisse aus den oben genannten Prüfungen über die Formel =WENN(UND($B$2<>"";SUMME(I6:P6)=3);"ja";"")&WENN(UND($B$2="";SUMME(I6:P6)=2);"ja";""), hier stellvertretend in der Zelle Q6, so aufbereitet, dass wenn alle erforderlichen Kriterien übereinstimmen, die Funktion ein ja zurückgibt. Das bedeutet, dass dieser Datensatz gesucht wird.

Software Excel: Excel-Datenbankfunktionen

© Archiv

Mit der bedingten Formatierung können Sie die gefundenen Datensätze zur Anzeige bringen

4. Nun müssen Sie das Prüfergebnis nur noch an die bedingte Formatierung "übergeben" und schon werden die gefundenen Datensätze farblich hervorgehoben. Markieren Sie hierfür den Bereich A6:E19 und rufen Sie über das Menü Format den Befehl Bedingte Formatierung auf.

Tragen Sie dort die Formel =$Q6="ja" ein und wählen Sie dann über die Befehlsschaltfläche Format und die Registerkarte Muster die gewünschte Hintergrundfarbe aus, bevor Sie den Dialog mit OK wieder verlassen. Die Hilfsspalten können Sie ausblenden und auch analog die übrigen Kriterien analog über zusätzliche Hilfszellen in die Prüfung mit einbinden.

Mehr zum Thema

Word - Text um Bild
Office-Tipp

In Word 2010 und 2013 gibt es Bilderrahmen mit einer pfiffigen Funktion für das Freistellen von Bildinhalten. Wir zeigen, wie es geht.
Wir zeigen den normgerechten Aufbau bei Briefen mit Microsoft Word.
Anleitung

Ein DIN-gerechter Aufbau erleichtert dem Lesenden die Übersicht. Word bietet dafür mit seinen Vorlagen und Funktionen alle Voraussetzungen.
Excel - Nettoarbeitstage
Office-Tipp

Wir erklären, wie Sie in Excel etwa für eine Arbeits- oder Urlaubsplanung die Wochenenden herausrechnen und die Nettoarbeitstage berechnen.
Kalender synchronisiert auf iPad
Zeit-Management

Kalender auf dem Smartphone, PC und im Web synchronisieren - mit unseren 9 Tipps schaffen Sie genau das. Verpassen Sie keinen Termin mehr!
Outlook - Logo
Office-Tipp

Wir zeigen, wie Sie in Outlook die Kalenderwoche anzeigen lassen können. Unser Office-Tipps sorgt für Durchblick bei der Terminplanung.